App compatiblity

Always check your devices compatibility before purchase:

  • iOS version 8.0 and up
  • Android 4.4 and up
  • NOT COMPATIBLE with Huawei P8 Lite and iPhone 5 (is compatible with iPhone 5s)